re = /"unavailablePosts"\s*:\s*\[([\s\S]*?)\],/
str = '"unavailablePosts": ["AA", "BB"],'
subst = '"unavailablePosts": "XXX",'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result