using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""unavailablePosts""\s*:\s*\[([\s\S]*?)\],";
string substitution = @"""unavailablePosts"": ""XXX"",";
string input = @"""unavailablePosts"": [""AA"", ""BB""],";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}