const regex = /"unavailablePosts"\s*:\s*\[([\s\S]*?)\],/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"unavailablePosts"\\s*:\\s*\\[([\\s\\S]*?)\\],', 'g')
const str = `"unavailablePosts": ["AA", "BB"],`;
const subst = `"unavailablePosts": "XXX",`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);