use strict;
my $str = '"unavailablePosts": ["AA", "BB"],';
my $regex = qr/"unavailablePosts"\s*:\s*\[([\s\S]*?)\],/p;
my $subst = '"unavailablePosts": "XXX",';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";