# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(?=\d+\.)|,//gm;t' <<< "12,345.45
12,345,789.45
10.000.00
123.45
12345
12,345"