const regex = /\.(?=\d+\.)|,/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(?=\\d+\\.)|,', 'gm')
const str = `12,345.45
12,345,789.45
10.000.00
123.45
12345
12,345`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);