re = /\.(?=\d+\.)|,/m
str = '12,345.45
12,345,789.45
10.000.00
123.45
12345
12,345'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result