$re = '/\.(?=\d+\.)|,/m';
$str = '12,345.45
12,345,789.45
10.000.00
123.45
12345
12,345';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;