#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\.(?=\d+\.)|,"
Local $sString = "12,345.45" & @CRLF & _
                "12,345,789.45" & @CRLF & _
                "10.000.00" & @CRLF & _
                "123.45" & @CRLF & _
                "12345" & @CRLF & _
                "12,345"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)