use strict;
my $str = '12,345.45
12,345,789.45
10.000.00
123.45
12345
12,345';
my $regex = qr/\.(?=\d+\.)|,/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";