using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(?=\d+\.)|,";
string substitution = @"";
string input = @"12,345.45
12,345,789.45
10.000.00
123.45
12345
12,345";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}