import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.(?=\\d+\\.)|,";
final String string = "12,345.45\n"
+ "12,345,789.45\n"
+ "10.000.00\n"
+ "123.45\n"
+ "12345\n"
+ "12,345";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}