#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\/?images\/(?!.*\bignore\b)[^.]*\.(?:png|jpe?g|gif|svg|tiff|other_extensions)"
Local $sString = "/images/image-filename-ignore.png" & @CRLF & _
"/images/image-filename-ignores.JPEG" & @CRLF & _
"/images/image-filename-notignore.PNG" & @CRLF & _
"/images/image-filename-ignore.GIF" & @CRLF & _
"/images/image-filename-ignores.JPG" & @CRLF & _
"images/image-filename-notignore.TIFF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")