re = /\/?images\/(?!.*\bignore\b)[^.]*\.(?:png|jpe?g|gif|svg|tiff|other_extensions)/mi
str = '/images/image-filename-ignore.png
/images/image-filename-ignores.JPEG
/images/image-filename-notignore.PNG
/images/image-filename-ignore.GIF
/images/image-filename-ignores.JPG
images/image-filename-notignore.TIFF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end