const regex = /\/?images\/(?!.*\bignore\b)[^.]*\.(?:png|jpe?g|gif|svg|tiff|other_extensions)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/?images\\\/(?!.*\\bignore\\b)[^.]*\\.(?:png|jpe?g|gif|svg|tiff|other_extensions)', 'gmi')
const str = `/images/image-filename-ignore.png
/images/image-filename-ignores.JPEG
/images/image-filename-notignore.PNG
/images/image-filename-ignore.GIF
/images/image-filename-ignores.JPG
images/image-filename-notignore.TIFF`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}