use strict;
my $str = '/images/image-filename-ignore.png
/images/image-filename-ignores.JPEG
/images/image-filename-notignore.PNG
/images/image-filename-ignore.GIF
/images/image-filename-ignores.JPG
images/image-filename-notignore.TIFF';
my $regex = qr/\/?images\/(?!.*\bignore\b)[^.]*\.(?:png|jpe?g|gif|svg|tiff|other_extensions)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}