import re
regex = re.compile(r"\/?images\/(?!.*\bignore\b)[^.]*\.(?:png|jpe?g|gif|svg|tiff|other_extensions)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("/images/image-filename-ignore.png\n"
"/images/image-filename-ignores.JPEG\n"
"/images/image-filename-notignore.PNG\n"
"/images/image-filename-ignore.GIF\n"
"/images/image-filename-ignores.JPG\n"
"images/image-filename-notignore.TIFF")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")