$re = '/\/?images\/(?!.*\bignore\b)[^.]*\.(?:png|jpe?g|gif|svg|tiff|other_extensions)/mi';
$str = '/images/image-filename-ignore.png
/images/image-filename-ignores.JPEG
/images/image-filename-notignore.PNG
/images/image-filename-ignore.GIF
/images/image-filename-ignores.JPG
images/image-filename-notignore.TIFF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);