# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?>\V*\n){9,}\V*$()/$1(\$1)is for replace all text with nothing (remoove all text)/gm;t' <<< "LINE 1
LINE 2
LINE 3
LINE 4
LINE 5
LINE 6
LINE 7
LINE 8
LINE 9
LINE 10"