# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?>\V*\n){9,}\V*$()"
test_str = ("LINE 1\n"
"LINE 2\n"
"LINE 3\n"
"LINE 4\n"
"LINE 5\n"
"LINE 6\n"
"LINE 7\n"
"LINE 8\n"
"LINE 9\n"
"LINE 10")
subst = "$1(\\$1)is for replace all text with nothing (remoove all text)"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.