$re = '/^(?>\V*\n){9,}\V*$()/m';
$str = 'LINE 1
LINE 2
LINE 3
LINE 4
LINE 5
LINE 6
LINE 7
LINE 8
LINE 9
LINE 10';
$subst = "$1(\$1)is for replace all text with nothing (remoove all text)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;