#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?>\V*\n){9,}\V*$()"
Local $sString = "LINE 1" & @CRLF & _
"LINE 2" & @CRLF & _
"LINE 3" & @CRLF & _
"LINE 4" & @CRLF & _
"LINE 5" & @CRLF & _
"LINE 6" & @CRLF & _
"LINE 7" & @CRLF & _
"LINE 8" & @CRLF & _
"LINE 9" & @CRLF & _
"LINE 10"
Local $sSubst = "$1(\$1)is for replace all text with nothing (remoove all text)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)