const regex = /^(?>\V*\n){9,}\V*$()/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?>\\V*\\n){9,}\\V*$()', 'gm')
const str = `LINE 1
LINE 2
LINE 3
LINE 4
LINE 5
LINE 6
LINE 7
LINE 8
LINE 9
LINE 10`;
const subst = `$1(\$1)is for replace all text with nothing (remoove all text)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);