import Foundation
let pattern = #"^(?>\V*\n){9,}\V*$()"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
LINE 1
LINE 2
LINE 3
LINE 4
LINE 5
LINE 6
LINE 7
LINE 8
LINE 9
LINE 10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1(\$1)is for replace all text with nothing (remoove all text)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)