use strict;
my $str = 'LINE 1
LINE 2
LINE 3
LINE 4
LINE 5
LINE 6
LINE 7
LINE 8
LINE 9
LINE 10';
my $regex = qr/^(?>\V*\n){9,}\V*$()/mp;
my $subst = '$1(\\$1)is for replace all text with nothing (remoove all text)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";