# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\tilde[\s+]?[\n+]?(\\alpha|\\beta|\\gamma|[A-Za-hj-z]+)/\\wtilde{$1}/gm;t' <<< "$\tilde \alpha(\Aff(X))$
$\tilde \beta|_{H_1^{\mathrm{st}}(X)}$
$\tilde{\alpha}(\Aff(X))$
$\tilde{\gamma}|_{H_1^{\mathrm{st}}(X)}$
$\tilde
\alpha(\Aff(X))$
$\tilde
\gamma|_{H_1^{\mathrm{st}}(X)}$
$\tilde
{\alpha}(\Aff(X))$
$\tilde
{\alpha}|_{H_1^{\mathrm{st}}(X)}$
%%%%%%%%%%%%%%%%%%%%%%%%
$\tilde A(\Aff(X))$
$\tilde B|_{H_1^{\mathrm{st}}(X)}$
$\tilde{A}(\Aff(X))$
$\tilde{B}|_{H_1^{\mathrm{st}}(X)}$
$\tilde
A(\Aff(X))$
$\tilde
B|_{H_1^{\mathrm{st}}(X)}$
$\tilde i$
$\tilde
{a}(\Aff(X))$
$\tilde
{i}|_{H_1^{\mathrm{st}}(X)}$"