use strict;
my $str = '$\\tilde \\alpha(\\Aff(X))$
$\\tilde \\beta|_{H_1^{\\mathrm{st}}(X)}$
$\\tilde{\\alpha}(\\Aff(X))$
$\\tilde{\\gamma}|_{H_1^{\\mathrm{st}}(X)}$
$\\tilde
\\alpha(\\Aff(X))$
$\\tilde
\\gamma|_{H_1^{\\mathrm{st}}(X)}$
$\\tilde
{\\alpha}(\\Aff(X))$
$\\tilde
{\\alpha}|_{H_1^{\\mathrm{st}}(X)}$
%%%%%%%%%%%%%%%%%%%%%%%%
$\\tilde A(\\Aff(X))$
$\\tilde B|_{H_1^{\\mathrm{st}}(X)}$
$\\tilde{A}(\\Aff(X))$
$\\tilde{B}|_{H_1^{\\mathrm{st}}(X)}$
$\\tilde
A(\\Aff(X))$
$\\tilde
B|_{H_1^{\\mathrm{st}}(X)}$
$\\tilde i$
$\\tilde
{a}(\\Aff(X))$
$\\tilde
{i}|_{H_1^{\\mathrm{st}}(X)}$';
my $regex = qr/\\tilde[\s+]?[\n+]?(\\alpha|\\beta|\\gamma|[A-Za-hj-z]+)/mp;
my $subst = '\\\\wtilde{$1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";