import re
regex = re.compile(r"\\tilde[\s+]?[\n+]?(\\alpha|\\beta|\\gamma|[A-Za-hj-z]+)", flags=re.MULTILINE)
test_str = ("$\\tilde \\alpha(\\Aff(X))$\n"
"$\\tilde \\beta|_{H_1^{\\mathrm{st}}(X)}$\n\n"
"$\\tilde{\\alpha}(\\Aff(X))$\n"
"$\\tilde{\\gamma}|_{H_1^{\\mathrm{st}}(X)}$\n\n"
"$\\tilde \n"
"\\alpha(\\Aff(X))$\n"
"$\\tilde \n"
"\\gamma|_{H_1^{\\mathrm{st}}(X)}$\n\n"
"$\\tilde \n"
"{\\alpha}(\\Aff(X))$\n"
"$\\tilde \n"
"{\\alpha}|_{H_1^{\\mathrm{st}}(X)}$\n\n"
"%%%%%%%%%%%%%%%%%%%%%%%%\n\n"
"$\\tilde A(\\Aff(X))$\n"
"$\\tilde B|_{H_1^{\\mathrm{st}}(X)}$\n\n"
"$\\tilde{A}(\\Aff(X))$\n"
"$\\tilde{B}|_{H_1^{\\mathrm{st}}(X)}$\n\n"
"$\\tilde \n"
"A(\\Aff(X))$\n"
"$\\tilde \n"
"B|_{H_1^{\\mathrm{st}}(X)}$\n\n"
"$\\tilde i$\n\n"
"$\\tilde \n"
"{a}(\\Aff(X))$\n"
"$\\tilde \n"
"{i}|_{H_1^{\\mathrm{st}}(X)}$")
subst = "\\\\wtilde{$1}"
result = regex.sub(subst, test_str)
if result:
print(result)