using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\tilde[\s+]?[\n+]?(\\alpha|\\beta|\\gamma|[A-Za-hj-z]+)";
string substitution = @"\\wtilde{$1}";
string input = @"$\tilde \alpha(\Aff(X))$
$\tilde \beta|_{H_1^{\mathrm{st}}(X)}$
$\tilde{\alpha}(\Aff(X))$
$\tilde{\gamma}|_{H_1^{\mathrm{st}}(X)}$
$\tilde
\alpha(\Aff(X))$
$\tilde
\gamma|_{H_1^{\mathrm{st}}(X)}$
$\tilde
{\alpha}(\Aff(X))$
$\tilde
{\alpha}|_{H_1^{\mathrm{st}}(X)}$
%%%%%%%%%%%%%%%%%%%%%%%%
$\tilde A(\Aff(X))$
$\tilde B|_{H_1^{\mathrm{st}}(X)}$
$\tilde{A}(\Aff(X))$
$\tilde{B}|_{H_1^{\mathrm{st}}(X)}$
$\tilde
A(\Aff(X))$
$\tilde
B|_{H_1^{\mathrm{st}}(X)}$
$\tilde i$
$\tilde
{a}(\Aff(X))$
$\tilde
{i}|_{H_1^{\mathrm{st}}(X)}$";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}