const regex = /\\tilde[\s+]?[\n+]?(\\alpha|\\beta|\\gamma|[A-Za-hj-z]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\tilde[\\s+]?[\\n+]?(\\\\alpha|\\\\beta|\\\\gamma|[A-Za-hj-z]+)', 'gm')
const str = `\$\\tilde \\alpha(\\Aff(X))\$
\$\\tilde \\beta|_{H_1^{\\mathrm{st}}(X)}\$
\$\\tilde{\\alpha}(\\Aff(X))\$
\$\\tilde{\\gamma}|_{H_1^{\\mathrm{st}}(X)}\$
\$\\tilde
\\alpha(\\Aff(X))\$
\$\\tilde
\\gamma|_{H_1^{\\mathrm{st}}(X)}\$
\$\\tilde
{\\alpha}(\\Aff(X))\$
\$\\tilde
{\\alpha}|_{H_1^{\\mathrm{st}}(X)}\$
%%%%%%%%%%%%%%%%%%%%%%%%
\$\\tilde A(\\Aff(X))\$
\$\\tilde B|_{H_1^{\\mathrm{st}}(X)}\$
\$\\tilde{A}(\\Aff(X))\$
\$\\tilde{B}|_{H_1^{\\mathrm{st}}(X)}\$
\$\\tilde
A(\\Aff(X))\$
\$\\tilde
B|_{H_1^{\\mathrm{st}}(X)}\$
\$\\tilde i\$
\$\\tilde
{a}(\\Aff(X))\$
\$\\tilde
{i}|_{H_1^{\\mathrm{st}}(X)}\$`;
const subst = `\\wtilde{$1}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);