$re = '/\\\\tilde[\s+]?[\n+]?(\\\\alpha|\\\\beta|\\\\gamma|[A-Za-hj-z]+)/m';
$str = '$\\tilde \\alpha(\\Aff(X))$
$\\tilde \\beta|_{H_1^{\\mathrm{st}}(X)}$
$\\tilde{\\alpha}(\\Aff(X))$
$\\tilde{\\gamma}|_{H_1^{\\mathrm{st}}(X)}$
$\\tilde
\\alpha(\\Aff(X))$
$\\tilde
\\gamma|_{H_1^{\\mathrm{st}}(X)}$
$\\tilde
{\\alpha}(\\Aff(X))$
$\\tilde
{\\alpha}|_{H_1^{\\mathrm{st}}(X)}$
%%%%%%%%%%%%%%%%%%%%%%%%
$\\tilde A(\\Aff(X))$
$\\tilde B|_{H_1^{\\mathrm{st}}(X)}$
$\\tilde{A}(\\Aff(X))$
$\\tilde{B}|_{H_1^{\\mathrm{st}}(X)}$
$\\tilde
A(\\Aff(X))$
$\\tilde
B|_{H_1^{\\mathrm{st}}(X)}$
$\\tilde i$
$\\tilde
{a}(\\Aff(X))$
$\\tilde
{i}|_{H_1^{\\mathrm{st}}(X)}$';
$subst = "\\wtilde{$1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;