import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\tilde[\\s+]?[\\n+]?(\\\\alpha|\\\\beta|\\\\gamma|[A-Za-hj-z]+)";
final String string = "$\\tilde \\alpha(\\Aff(X))$\n"
+ "$\\tilde \\beta|_{H_1^{\\mathrm{st}}(X)}$\n\n"
+ "$\\tilde{\\alpha}(\\Aff(X))$\n"
+ "$\\tilde{\\gamma}|_{H_1^{\\mathrm{st}}(X)}$\n\n"
+ "$\\tilde \n"
+ "\\alpha(\\Aff(X))$\n"
+ "$\\tilde \n"
+ "\\gamma|_{H_1^{\\mathrm{st}}(X)}$\n\n"
+ "$\\tilde \n"
+ "{\\alpha}(\\Aff(X))$\n"
+ "$\\tilde \n"
+ "{\\alpha}|_{H_1^{\\mathrm{st}}(X)}$\n\n"
+ "%%%%%%%%%%%%%%%%%%%%%%%%\n\n"
+ "$\\tilde A(\\Aff(X))$\n"
+ "$\\tilde B|_{H_1^{\\mathrm{st}}(X)}$\n\n"
+ "$\\tilde{A}(\\Aff(X))$\n"
+ "$\\tilde{B}|_{H_1^{\\mathrm{st}}(X)}$\n\n"
+ "$\\tilde \n"
+ "A(\\Aff(X))$\n"
+ "$\\tilde \n"
+ "B|_{H_1^{\\mathrm{st}}(X)}$\n\n"
+ "$\\tilde i$\n\n"
+ "$\\tilde \n"
+ "{a}(\\Aff(X))$\n"
+ "$\\tilde \n"
+ "{i}|_{H_1^{\\mathrm{st}}(X)}$";
final String subst = "\\\\wtilde{$1}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}