import Foundation
let pattern = #"\\tilde[\s+]?[\n+]?(\\alpha|\\beta|\\gamma|[A-Za-hj-z]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
$\tilde \alpha(\Aff(X))$
$\tilde \beta|_{H_1^{\mathrm{st}}(X)}$
$\tilde{\alpha}(\Aff(X))$
$\tilde{\gamma}|_{H_1^{\mathrm{st}}(X)}$
$\tilde
\alpha(\Aff(X))$
$\tilde
\gamma|_{H_1^{\mathrm{st}}(X)}$
$\tilde
{\alpha}(\Aff(X))$
$\tilde
{\alpha}|_{H_1^{\mathrm{st}}(X)}$
%%%%%%%%%%%%%%%%%%%%%%%%
$\tilde A(\Aff(X))$
$\tilde B|_{H_1^{\mathrm{st}}(X)}$
$\tilde{A}(\Aff(X))$
$\tilde{B}|_{H_1^{\mathrm{st}}(X)}$
$\tilde
A(\Aff(X))$
$\tilde
B|_{H_1^{\mathrm{st}}(X)}$
$\tilde i$
$\tilde
{a}(\Aff(X))$
$\tilde
{i}|_{H_1^{\mathrm{st}}(X)}$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\wtilde{$1}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)