#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(https://www.health.gov.au/.*)"
Local $sString = "https://www.health.gov.au/health-topics" & @CRLF & _
"https://www.health.gov.au/" & @CRLF & _
"https://www.health.gov.au/abc" & @CRLF & _
"https://www.health.gov.au/abc-123/333/&fsdfsdfds.htm" & @CRLF & _
"https://www.health.gov.au/hiidfiidfjdabc-123/333/&fsdfsdfds.htm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")