using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https://www.health.gov.au/.*)";
string input = @"https://www.health.gov.au/health-topics
https://www.health.gov.au/
https://www.health.gov.au/abc
https://www.health.gov.au/abc-123/333/&fsdfsdfds.htm
https://www.health.gov.au/hiidfiidfjdabc-123/333/&fsdfsdfds.htm";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}