import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https://www.health.gov.au/.*)";
final String string = "https://www.health.gov.au/health-topics\n"
+ "https://www.health.gov.au/\n"
+ "https://www.health.gov.au/abc\n"
+ "https://www.health.gov.au/abc-123/333/&fsdfsdfds.htm\n"
+ "https://www.health.gov.au/hiidfiidfjdabc-123/333/&fsdfsdfds.htm";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}