package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https://www.health.gov.au/.*)`)
var str = `https://www.health.gov.au/health-topics
https://www.health.gov.au/
https://www.health.gov.au/abc
https://www.health.gov.au/abc-123/333/&fsdfsdfds.htm
https://www.health.gov.au/hiidfiidfjdabc-123/333/&fsdfsdfds.htm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}