import Foundation
let pattern = #"(https://www.health.gov.au/.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.health.gov.au/health-topics
https://www.health.gov.au/
https://www.health.gov.au/abc
https://www.health.gov.au/abc-123/333/&fsdfsdfds.htm
https://www.health.gov.au/hiidfiidfjdabc-123/333/&fsdfsdfds.htm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)