const regex = new RegExp('(https://www.health.gov.au/.*)', 'gm')
const str = `https://www.health.gov.au/health-topics
https://www.health.gov.au/
https://www.health.gov.au/abc
https://www.health.gov.au/abc-123/333/&fsdfsdfds.htm
https://www.health.gov.au/hiidfiidfjdabc-123/333/&fsdfsdfds.htm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}