import re
regex = re.compile(r"(https://www.health.gov.au/.*)", flags=re.MULTILINE)
test_str = ("https://www.health.gov.au/health-topics\n"
"https://www.health.gov.au/\n"
"https://www.health.gov.au/abc\n"
"https://www.health.gov.au/abc-123/333/&fsdfsdfds.htm\n"
"https://www.health.gov.au/hiidfiidfjdabc-123/333/&fsdfsdfds.htm")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")