re = /(https:\/\/www.health.gov.au\/.*)/m
str = 'https://www.health.gov.au/health-topics
https://www.health.gov.au/
https://www.health.gov.au/abc
https://www.health.gov.au/abc-123/333/&fsdfsdfds.htm
https://www.health.gov.au/hiidfiidfjdabc-123/333/&fsdfsdfds.htm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end