# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!\p{Pd})[\p{P}\p{S}]//g;t' <<< "schöner co-operative two_words!@#$%^"