#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?!\p{Pd})[\p{P}\p{S}]"
Local $sString = "schöner co-operative two_words!@#$%^"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)