$re = '/(?!\p{Pd})[\p{P}\p{S}]/';
$str = 'schöner co-operative two_words!@#$%^';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;