import Foundation
let pattern = #"(?!\p{Pd})[\p{P}\p{S}]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"schöner co-operative two_words!@#$%^"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)