const regex = /(?!\p{Pd})[\p{P}\p{S}]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!\\p{Pd})[\\p{P}\\p{S}]', 'g')
const str = `schöner co-operative two_words!@#\$%^`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);