using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\p{Pd})[\p{P}\p{S}]";
string substitution = @"";
string input = @"schöner co-operative two_words!@#$%^";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}