re = /(?!\p{Pd})[\p{P}\p{S}]/
str = 'schöner co-operative two_words!@#$%^'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result