use strict;
my $str = 'schöner co-operative two_words!@#$%^';
my $regex = qr/(?!\p{Pd})[\p{P}\p{S}]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";