#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b([-'])\b|(?!\n)[\W_]"
Local $sString = "That's" & @CRLF & _
"a-" & @CRLF & _
"tasty" & @CRLF & _
"tic-tac." & @CRLF & _
"Or" & @CRLF & _
"-not?"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)